Umlaute im vi

Umlaute sollten in der heutigen Zeit eigentlich keine Probleme mehr darstellen. Eigentlich!

Denn meldet man sich über den Putty z.B auf einem Linux Server an, dessen Spracheinstellungen:

> locale
LANG=de_DE.UTF-8
LC_CTYPE="de_DE.UTF-8"
LC_NUMERIC="de_DE.UTF-8"
LC_TIME="de_DE.UTF-8"
LC_COLLATE="de_DE.UTF-8"
LC_MONETARY="de_DE.UTF-8"
LC_MESSAGES="de_DE.UTF-8"
LC_PAPER="de_DE.UTF-8"
LC_NAME="de_DE.UTF-8"
LC_ADDRESS="de_DE.UTF-8"
LC_TELEPHONE="de_DE.UTF-8"
LC_MEASUREMENT="de_DE.UTF-8"
LC_IDENTIFICATION="de_DE.UTF-8"
LC_ALL=

durchaus Umlaute unterstützen sollte, es aber dennoch nicht möglich ist, diese im Editor vi einzugeben, dann hat man doch ein Problem.

Schuld ist in diesem Fall aber weder der vi oder dessen größerer Bruder vim, sondern die Einstellungen vom Putty. Diese sollte man auch (über change settings -> Translation) auf UTF-8 umstellen.

Dann klappt es auch mit den Umlauten.

3 Kommentare

  1. Markus · · Antwort

    Hi Gero,

    cool, man lernt doch immer wieder gerne etwas dazu.

    Gruß

    Markus

  2. Die Nase · · Antwort

    Moin Bruderherz,

    ich darf Dir von Jan ein großes Dankeschön für den Artikel sagen.

    Gruß die Nase

  3. Peter · · Antwort

    Vielen Dank! Habe etwas suchen müssen…

Kommentar verfassen

Trage deine Daten unten ein oder klicke ein Icon um dich einzuloggen:

WordPress.com-Logo

Du kommentierst mit Deinem WordPress.com-Konto. Abmelden / Ändern )

Twitter-Bild

Du kommentierst mit Deinem Twitter-Konto. Abmelden / Ändern )

Facebook-Foto

Du kommentierst mit Deinem Facebook-Konto. Abmelden / Ändern )

Google+ Foto

Du kommentierst mit Deinem Google+-Konto. Abmelden / Ändern )

Verbinde mit %s

%d Bloggern gefällt das: